Ubuntu 10.10 sull’Acer Aspire One D260


< Update del 22/11/2010: CARD READER FUNZIONANTE!!! In fondo alla pagina per la procedura >

Ultimo acquisto, un Acer Aspire One D260 al pessimo prezzo di 299€.

Perché Acer? Continuo a lamentarmi della scadente qualità del telaio, di come ci “appiccicano” la componentistica e di quanto faccia schifo l’assistenza, ma alla fine ho sempre un maledetto acero tra le mani!

Dal mio laptop (Aspire 5920g), al monitor (H223HQ) e infine a questo netbook della mia fidanzata.

< Update del 05/03/2011: come volevasi dimostrare, dopo 7 mesi di vita si sono guastati alcune zone di tasti. L’ennesima conferma della scarsa qualità del prodotto! Attendo notizie dall’assistenza. >

Lo accendo e termino l’installazione di Windows 7, ovviamente preinstallato!

Sistema inutilizzabile, non riesco neppure a scaricare Firefox per i continui crash di Internet Explorer.

Ah, starà facendo gli aggiornamenti… bene, attendo con pazienza 2 riavvii per circa 60 update.

Dopo tutti gli aggiornamenti, stesso film: Explorer che si blocca, navigazione lentissima e, assurdo, neanche ad aprire l’esplora risorse.

Sarà l’antivirus MerdAfee preinstallato? Rimuoviamolo! Niente da fare… un sistema così lento avrebbe fatto incazzare anche San Francesco!

Ah, non si può nemmeno cambiare lo sfondo! Microsoft riesce sempre a farmi ridere…

Installo allora la Ubuntu Netbook Edition 10.04. Rinato! C’è stato meno tempo a installarsi il sistema operativo, cambiare lingua e fare tutti gli aggiornamenti che Windows a fare i soli aggiornamenti.

Stavo per scrivere un articolo, tipo “Acer: Windows? Ubuntu!” quando accade l’inevitabile: il lettore memory card non viene neppure visto dal sistema! E quello era proprio fondamentale per le cazzo di “fotine”.

Purtroppo finché i produttori hardware non si decidono a rilasciare i driver delle loro periferiche per Linux…

Ho provato infine con la beta di di Ubuntu 10.10 e, anche se non legge ancora le memory card, lsusb mi dice che ci sono segni di vita:

Bus 001 Device 006: ID 0cf2:6250 ENE Technology, Inc.
Device Descriptor:
 bLength                18
 bDescriptorType         1
 bcdUSB               2.00
 bDeviceClass            0 (Defined at Interface level)
 bDeviceSubClass         0
 bDeviceProtocol         0
 bMaxPacketSize0        64
 idVendor           0x0cf2 ENE Technology, Inc.
 idProduct          0x6250
 bcdDevice            1.00
 iManufacturer           1 ENE Flash  
 iProduct                2 UB6250       
 iSerial                 4 606569746801
 bNumConfigurations      1
 Configuration Descriptor:
 bLength                 9
 bDescriptorType         2
 wTotalLength           32
 bNumInterfaces          1
 bConfigurationValue     1
 iConfiguration          0
 bmAttributes         0x80
 (Bus Powered)
 MaxPower              498mA
 Interface Descriptor:
 bLength                 9
 bDescriptorType         4
 bInterfaceNumber        0
 bAlternateSetting       0
 bNumEndpoints           2
 bInterfaceClass       255 Vendor Specific Class
 bInterfaceSubClass      6
 bInterfaceProtocol     80
 iInterface              0
 Endpoint Descriptor:
 bLength                 7
 bDescriptorType         5
 bEndpointAddress     0x01  EP 1 OUT
 bmAttributes            2
 Transfer Type            Bulk
 Synch Type               None
 Usage Type               Data
 wMaxPacketSize     0x0200  1x 512 bytes
 bInterval               0
 Endpoint Descriptor:
 bLength                 7
 bDescriptorType         5
 bEndpointAddress     0x82  EP 2 IN
 bmAttributes            2
 Transfer Type            Bulk
 Synch Type               None
 Usage Type               Data
 wMaxPacketSize     0x0200  1x 512 bytes
 bInterval               0
Device Qualifier (for other device speed):
 bLength                10
 bDescriptorType         6
 bcdUSB               2.00
 bDeviceClass            0 (Defined at Interface level)
 bDeviceSubClass         0
 bDeviceProtocol         0
 bMaxPacketSize0        64
 bNumConfigurations      1
Device Status:     0x0000
 (Bus Powered)

Confido allora che con la nuova versione di Canonical ci siano speranze di un riconoscimento hardware al 100%

Update del 22/11/2010: CARD READER FUNZIONANTE!!!

Ecco la procedura:

1) Scaricate il seguente file:

https://bugs.launchpad.net/linux/+bug/530277/+attachment/1714152/+files/keucr.tgz

2) Estraete l’archivio

3) Aprite un terminale e spostatevi dentro la directory nella quale avete estratto il file

4) Digitate i seguenti comandi (attenzione che con l’ultimo comando riavviate il netbook):

cd keucr/
sudo apt-get install linux-headers-generic build-essential
make -C /usr/src/linux-headers-`uname -r` M=`pwd` modules
sudo make -C /usr/src/linux-headers-`uname -r` M=`pwd` modules_install
sudo depmod -a
sudo reboot

5) Godetevi il vostro netbook al 100%!
Procedura testata e funzionante su Ubuntu 10.10 con kernel 2.6.35-22

19 thoughts on “Ubuntu 10.10 sull’Acer Aspire One D260

  1. Blutz

    Grazie tante per la guida………………………………
    Grazieeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

  2. Raffaele

    Ciao,
    ma come si fa ad attivare la wireless se la combinazione Fn+F3 non viene riconosciuta? In Win 7 parte attiva di default e non vi è una opzione nel bios per attivarla indipendemente dal SO.
    Grazie mille!

  3. Raffaele

    Ciao,
    il problema e’ che e’ spenta la luce relativa alla wireless e non riesco ad attivarla.
    La scehda di rete mi sembra che venga riconosciuta. Il problema forse e’ che non vengono riconosciute le sequenze function della tastiera.
    La cosa strana e’ che la regolazione della luminosita’ del display invece mi funziona.

  4. Non uso Kubuntu, però non c’entra il DE… ti restituisce un errore durante la procedura che ho descritto oppure una volta riavviato non funziona?
    Nel caso non funzioni dopo il riavvio, mi posti l’output di:
    sudo fdisk -l

  5. andrea console

    allora forse il problema è che è un ACER ASPIRE 6930G, forse è cambiato il lettore?

    comunque l’output con una SD inserita è:

    Disco /dev/sda: 990 MB, 990904320 byte
    32 testine, 63 settori/tracce, 960 cilindri
    Unità = cilindri di 2016 * 512 = 1032192 byte
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Identificativo disco: 0x00000000

    Dispositivo Boot Start End Blocks Id System
    /dev/sda1 1 960 967613+ 6 FAT16

    Disco /dev/sdb: 250.1 GB, 250059350016 byte
    255 testine, 63 settori/tracce, 30401 cilindri
    Unità = cilindri di 16065 * 512 = 8225280 byte
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Identificativo disco: 0x000582ff

    Dispositivo Boot Start End Blocks Id System
    /dev/sdb1 * 1 29274 235139072 83 Linux
    /dev/sdb2 29274 30402 9057281 5 Esteso
    /dev/sdb5 29274 30402 9057280 82 Linux swap / Solaris

    grazie per l’interessamento!

  6. Belin! (tipica esclamazione savonese)
    E’ un altro computer… lo sarà sicuramente…
    cmd potrebbe essere lei!
    /dev/sda1 1 960 967613+ 6 FAT16

    fai un:
    sudo mount /dev/sda1 /mnt
    nautilus /mnt/

    cosa vedi?

  7. andrea

    grande! anche se “sudo mount /dev/sda1 /mnt” mi risponde con un poco confortante:

    mount: /dev/sda1 già montato o /mnt occupato
    mount: secondo mtab, /dev/sda1 è già montato su /mnt

    il comando dolphin /mnt/ apre la sd!

    ora potrei fare un link allo script e sarei a posto, a meno che tu non mi possa suggerire qualcosa di più brillante. Thanks!

  8. Iuri

    Puoi linkare la fonte? Sinceramente non me la sento molto di installare un modulo del kernel senza sapere da dove vieneO_o

  9. Iuri

    si vabe buona notte sto dormento; ho appena visto che il link del pacchetto è a launchpad… vediamo se riesce a convincermi xD

  10. markpersy

    vorrei sapere se inserendo le cuffie senti l’audio: ho notato che dalla 10.04 non mi funzionano più le cuffie, mentre nella 9.10 tutto andava perfettamente.
    grazie in anticipo (:

  11. markpersy

    hai fatto l’upgrade dalla 9.10 o installazione liscia? non so dove sbattere la testa😀

  12. Dario

    Ciao,
    complimenti per la guida. Ho lo stesso problema del lettore SD con l’HP mini 110-3100 con Ubuntu netbook edition 10.10.
    Avete qualche idea per aiutarmi. Grazie

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s